• POJ 3211 Washing Clothes


    Washing Clothes

    Time Limit: 1000MS Memory Limit: 131072K
    Total Submissions: 10738 Accepted: 3480
    Description

    Dearboy was so busy recently that now he has piles of clothes to wash. Luckily, he has a beautiful and hard-working girlfriend to help him. The clothes are in varieties of colors but each piece of them can be seen as of only one color. In order to prevent the clothes from getting dyed in mixed colors, Dearboy and his girlfriend have to finish washing all clothes of one color before going on to those of another color.

    From experience Dearboy knows how long each piece of clothes takes one person to wash. Each piece will be washed by either Dearboy or his girlfriend but not both of them. The couple can wash two pieces simultaneously. What is the shortest possible time they need to finish the job?

    Input

    The input contains several test cases. Each test case begins with a line of two positive integers M and N (M < 10, N < 100), which are the numbers of colors and of clothes. The next line contains M strings which are not longer than 10 characters and do not contain spaces, which the names of the colors. Then follow N lines describing the clothes. Each of these lines contains the time to wash some piece of the clothes (less than 1,000) and its color. Two zeroes follow the last test case.

    Output

    For each test case output on a separate line the time the couple needs for washing.

    Sample Input

    3 4
    red blue yellow
    2 red
    3 blue
    4 blue
    6 red
    0 0
    Sample Output

    10
    Source

    POJ Monthly–2007.04.01, dearboy

    题意男女朋友洗衣服,可以同时洗一种颜色的衣服,求最短时间。
    对于每种颜色的衣服,就是容量为洗衣服时间总和一半的01背包问题。
    代码

    #include<iostream>
    #include <cstdio>
    #include<algorithm>
    #include <cstring>
    #include <map>
    #include<vector>
    using namespace std;
    int dp[1000005];
    int main(){
    	int m,n;
    	while(cin>>m>>n&&(m||n)){
    		
    vector <int >x[11];
    		map<string,int>q;
    		string a;int b;
        	int sum[11]={0};
    		for(int i=0;i<m;i++)
    			{
    				cin>>a;
    				q[a]=i;}
    		for(int i=0;i<n;i++)
    			 {	cin>>b>>a;
            			 x[q[a]].push_back(b);
            			 sum[q[a]]+=b;
    				
    					}
    		int tot=0;
    		for(int i=0;i<m;i++)
    		{	
    		memset(dp,0,sizeof(dp));
                for(int j=0;j<x[i].size();j++)
    				for(int k=sum[i]/2;k>=x[i][j];k--)
    					dp[k]=max(dp[k],dp[k-x[i][j]]+x[i][j]);
    		
    		tot+=(sum[i]-dp[sum[i]/2]);
    		
    }
    		cout<<tot<<endl;
    	}
    	return 0;
    } 
    
    
  • 相关阅读:
    类加载机制
    PTA(BasicLevel)-1094 谷歌的招聘
    PTA(BasicLevel)-1023 组个最小数
    异构图神经网络笔记-Heterogeneous Graph Neural Network(KDD19)
    PTA(BasicLevel)-1014 福尔摩斯的约会
    PTA(BasicLevel)-1013 数素数
    PTA(BasicLevel)-1012 数字分类
    PTA(BasicLevel)-1010 一元多项式求导
    PTA(BasicLevel)-1009 说反话
    PTA(BasicLevel)-1008数组元素循环右移问题
  • 原文地址:https://www.cnblogs.com/lunatic-talent/p/12798995.html
Copyright © 2020-2023  润新知