• --hdu1498->二分图应用,行列不重复运算


    E - 50 years, 50 colors
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Appoint description: 

    Description

    On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons". 

    There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons. 

    Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times. 

     

    Input

    There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0. 
     

    Output

    For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1". 
     

    Sample Input

    1 1
    1
     
     
    2 1
    1 1
    1 2
     
    2 1
    1 2
    2 2
     
     
    5 4
    1 2 3 4 5
    2 3 4 5 1
    3 4 5 1 2
    4 5 1 2 3
    5 1 2 3 4
     
     
    3 3
    50 50 50
    50 50 50
    50 50 50
    0 0
     

    Sample Output

    -1
    1
    2
    1 2 3 4 5
    -1
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    int n;
    int ms[51][110][110];
    int match[110];
    int vis[110];
    int id;
    
    int hungray(int u){
    
        for(int i = 1;i<=n;i++){
    
            if(vis[i] == 0&&ms[id][u][i]){
                vis[i] = 1;
                if(match[i] == 0||hungray(match[i])){
                    match[i] = u;
                    return 1;
                }
            }
    
        }
    
       return 0;
    
    }
    
    int main(){
    
       int k;
       int x;
       int res[51];
    
       while(~scanf("%d%d",&n,&k),n||k){
    
           memset(res,0,sizeof(res));
           memset(ms,0,sizeof(ms));
    
           for(int i = 1;i<=n;i++)
           for(int j = 1;j<= n;j++){
                 scanf("%d",&x);
                 ms[x][i][j] = 1;
           }
    
    
           for(int i =1;i<=50;i++){
               id = i;
               memset(match,0,sizeof(match));
               int ans = 0;
               for(int j = 1;j <= n;j++){
                   memset(vis,0,sizeof(vis));
                   if(hungray(j))ans++;
               }
               res[i] = ans;
    
           }
           int flag  = 1;
           for(int i = 1;i<=50;i++){
    
                if(res[i] > k ){
                    if(flag){
                        printf("%d",i);
                        flag = 0;
                    }
                    else printf(" %d",i);
                }
    
           }
           if(flag)printf("-1");
           puts("");
       }
    
    }
    

      

  • 相关阅读:
    linux下设置SSH无密码登陆
    设置sudo权限
    集群重启后启动ambari-server访问Web页面无法启动集群解决
    使用Ambari部署hadoop集群
    centos7.6安装python3.7
    Locust
    测试框架(自然语言)
    Maven之(七)pom.xml配置文件详解
    git的使用
    elastic search(es)安装
  • 原文地址:https://www.cnblogs.com/lovelystone/p/4702081.html
Copyright © 2020-2023  润新知