• HDU2602(01背包)


    Bone Collector

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 23977    Accepted Submission(s): 9729


    Problem Description
    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
     
    Input
    The first line contain a integer T , the number of cases.
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the maximum of the total value (this number will be less than 231).
     
    Sample Input
    1 5 10 1 2 3 4 5 5 4 3 2 1
     
    Sample Output
    14
    //#define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<string>
    #include<algorithm>
    #define MAX 1100
    using namespace std;
    int dp[MAX][MAX];//行代表个数,列代表体积
    int w[MAX], v[MAX], n, W;
    int _search(int i, int j){
        if (dp[i][j] >= 0){
            return dp[i][j];
        }
        int res;
        if (i == n){
            res = 0;
        }
        else if (w[i] > j){
            res = _search(i + 1, j);
        }
        else{
            res = max(_search(i + 1, j), _search(i + 1, j - w[i]) + v[i]);
        }
        return dp[i][j] = res;
    }
    int main()
    {
        int T;
        cin >> T;
        while (T--){
            cin >> n >> W;
            for (int i = 0; i < n; i++){
                cin >>v[i];
            }
            for (int i = 0; i < n; i++){
                cin >> w[i];
            }
            memset(dp, -1, sizeof(dp));
            cout << _search(0,W) << endl;
        }
        
        system("pause");
        return 0;
    }

    做这道题的时候二逼了。其实主要是练习记忆搜索。看来递归并没有我想象中掌握的那么好,革命啥时候能成功啊。。。

    世上无难事,只要肯登攀。
  • 相关阅读:
    通过ip找mac
    python开发总结
    iptables 通用语句
    运行pyqt4生成py文件增加代码
    re正则match、search、findall、finditer函数方法使用
    python list 字符串排序
    读取yaml文件小方法
    递归解析字典小方法
    assert 断言
    格式化字符串——初级% 和format
  • 原文地址:https://www.cnblogs.com/littlehoom/p/3550547.html
Copyright © 2020-2023  润新知