• POJ 1936 All in All(简单的字符串的字符列)


    All in All

    Time Limit: 1000MS

     

    Memory Limit: 30000K

    Total Submissions: 21789

     

    Accepted: 8668

    Description

    You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

    Input

    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

    Output

    For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

    Sample Input

    sequence subsequence

    person compression

    VERDI vivaVittorioEmanueleReDiItalia

    caseDoesMatter CaseDoesMatter

    Sample Output

    Yes

    No

    Yes

    No

    Source

    Ulm Local 2002

     解题报告:就是字符串的子序列问题,匹配到最后时只要前面的单词按照顺序依次在后面的字符串中出现即可

    代码如下:

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cstdlib>
    const int N = 100010;
    char a[N], b[N];
    int main()
    {
    int lena, i, j, lenb;
    while (scanf("%s%s", a, b) != EOF)
    {
    lena = strlen(a);
    lenb = strlen(b);
    for (i = 0, j = 0; i < lenb; ++i)
    {
    if(b[i] == a[j])
    {
    ++j;
    }
    }
    if (j == lena)//匹配到最后时只要前面的单词按照顺序依次在后面的字符串中出现即可
    {
    printf("Yes\n");
    }
    else
    {
    printf("No\n");
    }
    }
    return 0;
    }



  • 相关阅读:
    使用淘宝Str2varlist与str2numlist 代替 in/exist ,提升性能(Oracle)
    由浅入深理解索引的实现
    你知道数据库索引的工作原理吗?
    深入理解数据库磁盘存储(Disk Storage)
    如何解析oracle执行计划
    Beyond Compare 4 最新中文版 注册码 key
    并发和并行的区别
    代码复用的规则
    Some Java exceptions, messages and errors.
    菜鸟学SSH(十六)——Struts2内部是如何工作的
  • 原文地址:https://www.cnblogs.com/lidaojian/p/2400940.html
Copyright © 2020-2023  润新知