• HDU ACM 1071 The area


    The area

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5234    Accepted Submission(s): 3666

    Problem Description
    Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

    Note: The point P1 in the picture is the vertex of the parabola.

     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
     
    Output
    For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
     
    Sample Input
    2
    5.000000 5.000000
    0.000000 0.000000
    10.000000 0.000000
    10.000000 10.000000
    1.000000 1.000000
    14.000000 8.222222
     
    Sample Output
    33.33
    40.69
    Hint
    For float may be not accurate enough, please use double instead of float.
     
    Author
    Ignatius.L
     
     
    #include<stdio.h>
    int main()
    {
        double x1=0, x2=0, x3=0, y1=0, y3=0, y2=0, a=0, b=0, c=0, k=0, ans=0, t=0;
        int n;
        scanf("%d", &n);
        while(n--)
        {
            scanf("%lf%lf", &x1,&y1);
            scanf("%lf%lf", &x2,&y2);
            scanf("%lf%lf", &x3,&y3);
            //y=ax^2+bx+c
            a = (y2-y1)/((x2-x1)*(x2-x1));
            b = 2*a*x1*(-1);
            c = a*x1*x1+y1;
            k = (y3-y2)/(x3-x2);
            t = y3-(k*x3);
            ans = 1.0/3*a*(x3*x3*x3-x2*x2*x2)+(b-k)*1.0/2*(x3*x3-x2*x2)+(c-t)*(x3-x2);
            printf("%.2lf\n", ans);
        }
        return 0;
    }

    解题报告:

    做这题发现了一个问题就是:a = (0.000000 - 5.000000)/(0.000000 - 5.000000)/(0.000000-5.000000) 结果a的值会等于-0.200000,不知道是否跟内存有关,现放着先,这题的思路是:计算面积回到了高中的知识就是计算函数所围成的面积,意味着要用到积分,推出公式自己套进去就行了。

  • 相关阅读:
    MongoDB 释放磁盘空间 db.runCommand({repairDatabase: 1 })
    RK 调试笔记
    RK Android7.1 拨号
    RK Android7.1 移植gt9271 TP偏移
    RK Android7.1 定制化 itvbox 盒子Launcher
    RK Android7.1 双屏显示旋转方向
    RK Android7.1 设置 内存条作假
    RK Android7.1 设置 蓝牙 已断开连接
    RK Android7.1 进入Camera2 亮度会增加
    RK 3128 调触摸屏 TP GT9XX
  • 原文地址:https://www.cnblogs.com/liaoguifa/p/2746956.html
Copyright © 2020-2023  润新知