• poj_1562Oil Deposits


    Oil Deposits
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 10451   Accepted: 5668

    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

    Output

    are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0

    Sample Output

    0
    1
    2
    2
    好吧,我是找最简单的DFS学习的,还是理解不深啊,难的不会啊

    #include<iostream>
    #include<fstream>
    using namespace std;
    const int moves[8][2] = {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
    char maps[105][105];
    int m, n;
    void dfs(int x, int y)
    {
    	int i, p, q;
    	maps[x][y] = '*';
    	for(i = 0; i < 8; i++)
    	{
    		p = x + moves[i][0];
    		q = y + moves[i][1];
    		if(p >= 1 && q >= 1 && p <= m && q <= n && maps[p][q]=='@')
    		{
    			dfs(p,q);
    		}
    	}
    }
    
    int main()
    {
    	ifstream cin("in.txt");
    	while(cin >> m >> n)
    	{
    		if(m == 0)
    		{
    			break;
    		}
    		for(int i = 1; i <= m; i++)
    		{
    			for(int j = 1; j <= n; j++)
    			{
    				cin >> maps[i][j];
    			}
    		}
    		int count = 0;
    		for(int i = 1; i <= m; i++)
    		{
    			for(int j = 1; j <= n; j++)
    			{
    				if(maps[i][j] == '@')
    				{
    					dfs(i, j);
    					count++;
    				}
    			}
    		}
    		cout << count << endl;
    	}
    }



  • 相关阅读:
    普通百姓如何应对通货膨胀
    经济
    将到来的战略转变:移动 Web 还是移动 Apps?
    ASP.Net 第一天笔记 MVC 控制器与视图数据传递注意事项
    关于阿里云 ETC服务器 端口开放问题
    .net 委托 +lamda表达式
    de4Dot用法 解决 .net程序 reflecter反编译 “索引超出了数组界限”问题
    fastReport.net 初了解
    关于JQuery Ajax 跨域 访问.net WebService
    JQuery AJAX 通过一般处理程序 取列表
  • 原文地址:https://www.cnblogs.com/lgh1992314/p/5835111.html
Copyright © 2020-2023  润新知