• HDU 1058 Humble Numbers


    Humble Numbers

    http://acm.hdu.edu.cn/showproblem.php?pid=1058

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 10972    Accepted Submission(s): 4780

    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
    Write a program to find and print the nth element in this sequence
     
    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     
    Sample Input
     
    1
    2
    3
    4
    11
    12
    13
    21
    22
    23
    100
    1000
    5842
    0
     
    Sample Output
     
    The 1st humble number is 1.
    The 2nd humble number is 2.
    The 3rd humble number is 3.
    The 4th humble number is 4.
    The 11th humble number is 12.
    The 12th humble number is 14.
    The 13th humble number is 15.
    The 21st humble number is 28.
    The 22nd humble number is 30.
    The 23rd humble number is 32.
    The 100th humble number is 450.
    The 1000th humble number is 385875. T
    he 5842nd humble number is 2000000000.
     
    Source
     
    Recommend
    JGShining
     
     
     
    题意大体是:humble number由2,3,5,7因数组成,,,然后解题即可,,,注意1的时候是1
     
     
     
    #include<stdio.h>
    
    long long num[5843];
    
    int main(){
        num[1]=1;
        int i,j,k;
        int prime[4]={2,3,5,7};
        for(i=2;i<=5842;i++){
            num[i]=2000000001;
            for(j=0;j<4;j++)
                for(k=i-1;k>=1;k--){
                    if(num[k]*prime[j]<=num[i-1])
                        break;
                    if(num[k]*prime[j]<num[i])
                        num[i]=num[k]*prime[j];
                }
        }
    
    
        int n;
        while(scanf("%d",&n) && n){
            printf("The %d",n);
            if(n%10==1 && n%100!=11)
                printf("st ");
            else if(n%10==2 && n%100!=12)
                printf("nd ");
            else if(n%10==3 && n%100!=13)
                printf("rd ");
            else
                printf("th ");
            printf("humble number is %I64d.\n",num[n]);
        }
        return 0;
    }
  • 相关阅读:
    gauss消元
    POJ1229 域名匹配
    HDU3487 play with chain
    POJ1185 炮兵阵地
    POJ2411
    sgu233 little kings
    树形DP初步-真树1662
    树形DP初步-二叉树1661
    c++——string类用法
    UVa1354 ——天平难题
  • 原文地址:https://www.cnblogs.com/jackge/p/2839022.html
Copyright © 2020-2023  润新知