• Happy 2006


    Happy 2006
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 6940   Accepted: 2192

    Description

    Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.
    Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

    Input

    The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

    Output

    Output the K-th element in a single line.

    Sample Input

    2006 1
    2006 2
    2006 3
    

    Sample Output

    1
    3
    5
    #include<iostream>  
    #include<cstdlib> 
    #include<cstdio> 
    #include<cstring> 
    #include<algorithm> 
    #include<cmath> 
    using namespace std; 
    int pri[1000000]; 
    int gcd ( int a , int b )  

        return b == 0 ? a : gcd ( b , a % b ) ; 

    int main() 

        int m , k ; 
      while ( cin >> m >> k )  
        { 
           int i , j ;       
        for ( i = 1 , j = 0 ; i <= m ; i ++ )      
         if ( gcd ( m , i ) == 1 ) 
                    pri [ j ++ ] = i ; 
           
          if ( k%j != 0) 
              cout <<k/j * m +pri[k%j-1] << endl;  //注意i与m互素,则i+km与m也互素,展转相除法可得出
           else//要特别考虑k%j=0的情况,因为数组是从0开始的,第i个对应的是pri[i-1] 
               cout << (k/j-1)*m+pri[j-1] << endl ; 
       } 
      return 0; 
    }


  • 相关阅读:
    2020.10.31
    2020.10.26
    2020.10.29
    2020.10.28动手动脑+验证
    2020.11.1(每周学习总结)
    2020.10.30
    2020.11.2动手动脑➕课后试验性问题
    Javascript权威指南阅读笔记第3章类型、值和变量(1)
    【一个小功能】从js判断ie版本,浅谈navigator对象的appName属性
    【Vue】vif与vshow的区别
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2607008.html
Copyright © 2020-2023  润新知