hdu1001
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
#include<iostream>
using namespace std;
int main()
{
int n, sum=0;
while (cin >> n)
{
for (int i = 1; i <= n; i++)
{
sum = sum + i;
}
cout << sum << endl << endl;
sum = 0;
}
}
大意:累加1+2+…+n,并输出一行空行;
注意点:有点坑要输出一空行,所以两次endl;
sum计算完要记得初始化,或者选择把sum定义放在里面。
e.g.
while()
{
int sum=0;
}