• 1035 Password (20 分)


    To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N (≤), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

    Output Specification:

    For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

    Sample Input 1:

    3
    Team000002 Rlsp0dfa
    Team000003 perfectpwd
    Team000001 R1spOdfa
     

    Sample Output 1:

    2
    Team000002 RLsp%dfa
    Team000001 R@spodfa
     

    Sample Input 2:

    1
    team110 abcdefg332
     

    Sample Output 2:

    There is 1 account and no account is modified
     

    Sample Input 3:

    2
    team110 abcdefg222
    team220 abcdefg333
     

    Sample Output 3:

    There are 2 accounts and no account is modified
    注意:n的单复数
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10010;
    typedef struct Stu{
        string user;
        string pwd;
    }stu;
    int main(){
        stu stus[maxn];
        int n,ls;
        cin>>n;
        int flag[maxn];
        for(int i=0;i<n;i++){
            cin>>stus[i].user;
            cin>>stus[i].pwd;
        }
        for(int i=0;i<n;i++){
            ls=stus[i].pwd.length();
            flag[i]=0;
            for(int j=0;j<ls;j++){
                if(stus[i].pwd[j]=='1'){
                    stus[i].pwd[j]='@';
                    flag[i]=1;
                }
                if(stus[i].pwd[j]=='0'){
                    stus[i].pwd[j]='%';
                    flag[i]=1;
                }
                if(stus[i].pwd[j]=='l'){
                    stus[i].pwd[j]='L';
                    flag[i]=1;
                }
                if(stus[i].pwd[j]=='O'){
                    stus[i].pwd[j]='o';
                    flag[i]=1;
                }
            }
        }
        int cnt=0;
        for(int i=0;i<n;i++){
            if(flag[i]==1){
                cnt++;
            }
        }
        if(cnt==0&&n!=1){
            cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
            return 0;
        }
        if(cnt==0&&n==1){
            cout<<"There is 1 account and no account is modified"<<endl;
            return 0;
        }
        cout<<cnt<<endl;
        for(int i=0;i<n;i++){
            if(flag[i]==1){
                cout<<stus[i].user<<" "<<stus[i].pwd<<endl;
            }
        }
        return 0;
    }
    
    

     优化代码:

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10010;
    vector<string> v;
    int main(){
        int n,ls;
        cin>>n;
        for(int i=0;i<n;i++){
            string name,s;
            cin>>name>>s;
            ls=s.length();
            int flag=0;
            for(int j=0;j<ls;j++){
                switch(s[j]){
                    case '1': s[j]='@'; flag=1;break;
                    case '0': s[j]='%'; flag=1;break;
                    case 'l':s[j]='L';flag=1;break;
                    case 'O':s[j]='o';flag=1;break;
                }
            }
            if(flag==1){
                string temp=name+" "+s;
                v.push_back(temp);
            }
        }
        int cnt;
        cnt=v.size();
        if(cnt!=0){
            cout<<cnt<<endl;
            for(int i=0;i<cnt;i++){
                cout<<v[i]<<endl;
            }
        }
        else if(n==1){
            cout<<"There is 1 account and no account is modified"<<endl;
        }
        else{
            cout<<"There are "<<n<<" accounts and no account is modified"<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    结构型设计模式(上)
    创建型设计模式(下)
    创建型设计模式(上)
    HTTP 简述
    MVC、MVP与MVVM架构模式
    PHP 部分语法(二)
    PHP 部分语法(一)
    TypeScript 学习笔记(四)
    WORD 和Uint16的区别
    extern的用法
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14364865.html
Copyright © 2020-2023  润新知