• 1011 World Cup Betting (20 分)


    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.1  1.6
    4.1  1.2  1.1

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%1)×2=39.31 yuans (accurate up to 2 decimal places).

    Input Specification:

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

    Output Specification:

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input:

    1.1 2.5 1.7
    1.2 3.1 1.6
    4.1 1.2 1.1

    Sample Output:

    T T W 39.31

    Submit:

    #include <iostream>
    using namespace std;
    //目标:求三场比赛最大收益 (4.1×3.1×2.5×65%−1)×2=39.31 
    int main() {
        float arr[3][3],sum=1.0; 
        char c[4] = {"WTL"};
        for (int i=0;i<3;i++) {
            float maxbet=0.0;
            int bet;
            for (int j=0;j<3;j++) {
                scanf("%f",&arr[i][j]);
                if (maxbet <= arr[i][j]) {
                    maxbet = arr[i][j];
                    bet = j;
                }
            }
            sum *= maxbet;
            printf("%c ",c[bet]);
        }
        printf("%.2f",(sum*0.65-1)*2);
        return 0;
    }

    参考:

    柳婼-https://blog.csdn.net/liuchuo/article/details/54561626

    昵称五个字-https://blog.csdn.net/a617976080/article/details/89676670

  • 相关阅读:
    java运算符优先级
    快排
    dpkg
    BZOJ 4487 染色问题
    BZOJ 3530 数数
    XSY 2754 求和
    BZOJ 4559 成绩比较
    广义容斥-二项式反演-容斥系数
    线性基学习笔记及其相关证明
    BZOJ 2754 喵星球上的点名
  • 原文地址:https://www.cnblogs.com/cgy-home/p/15128682.html
Copyright © 2020-2023  润新知