• 71


    本题要求从输入的N个整数中查找给定的X。如果找到,输出X的位置(从0开始数);如果没有找到,输出“Not Found”。

    输入格式:
    输入在第一行中给出两个正整数N(≤20)和X,第二行给出N个整数。数字均不超过长整型,其间以空格分隔。

    输出格式:
    在一行中输出X的位置,或者“Not Found”。

    输入样例1:
    5 7
    3 5 7 1 9
    输出样例1:
    2
    输入样例2:
    5 7
    3 5 8 1 9
    输出样例2:
    Not Found

    实验代码
    `#include <stdio.h>
    int main()
    {
    int n,x;
    scanf("%d %d", &n,&x);

    int search[20];
    int i;
    for(i=0;i<n;i++){
    	scanf("%d", &search[i]);
    }
    
    for(i=0; i<n; i++){
    	if(x==search[i]){
    		printf("%d", i);
    		break;
    	}
    }
    
    if(i==n){
    	printf("Not Found");
    }
    

    }`

    1.定义n,x
    2.输入n。x
    3.定义一个数组
    4.定义一个i
    5.使用循环结构寻找x的位置

  • 相关阅读:
    多层交换概述
    多层交换MLS笔记2
    多层交换MLS笔记1
    RSTP Proposal-Agreement
    RSTP Note
    保护STP
    优化STP
    Cisco STP Note
    25、C++的顶层const和底层const
    43、如何用代码判断大小端存储
  • 原文地址:https://www.cnblogs.com/bramblesrose/p/10447832.html
Copyright © 2020-2023  润新知