模拟类
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
Source
Tehran 2001
//
#include <iostream>
#include <string>
#include <iterator>
#include <vector>
using namespace std;
int main(int argc, char* argv[])
{
int cases;
int parentheses;
int brackets;
cin >> cases;
vector<bool> line;
vector<int> wseq;
for(int i = 0; i < cases ; ++i)
{
line.clear();
wseq.clear();
cin >> parentheses;
int k = 0;
for (int j = 0; j < parentheses; ++j)
{
cin >> brackets;
while (k < brackets)
{
++k;
line.push_back(true);
}
line.push_back(false);
}
for (int j = 0; j < line.size(); ++j)
{
if (line[j] == false)
{
int match = -1;
int k = j;
int cnt = 0;
while (match != 0)
{
--k;
if (line[k] == true) ++match, ++cnt;
else --match;
}
wseq.push_back(cnt);
}
}
copy(wseq.begin(),wseq.end(),ostream_iterator<int>(cout," "));
cout << "\n";
}
return 0;
}