• POJ 1004 Financial Management


    POJ 1004 Financial Management
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 204286   Accepted: 77740

    Description

    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    Input

    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

    Output

    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

    Sample Input

    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75

    Sample Output

    $1581.42

    Source

     
    AC:
    #include<iostream>
    #include<iomanip>
    using namespace std;
     
    int main(void)
    {
        double sum=0.0;
        for(int i=1;i<=12;i++)
        {
            double temp;
            cin>>temp;
            sum+=temp;
        }
        cout<<fixed<<setprecision(2)<<'$'<<sum/12.0<<endl;
        return 0;
    } 
  • 相关阅读:
    Vue过滤器使用
    vue基础
    lesson
    lesson
    lesson
    lesson
    rm 命令详解
    alias 命令详解
    cd 命令详解
    cut 命令详解
  • 原文地址:https://www.cnblogs.com/alan-blog-TsingHua/p/10640030.html
Copyright © 2020-2023  润新知