• 1008 Elevator (20 分)(模拟)


    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    

    Sample Output:

    41

    题解:看懂题意模拟过程即可,水题

    代码:

    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    int main() {
    	long long int sum=0;
    	int n;
    
    	while(scanf("%d",&n)!=EOF) {
    		int a[10005]= {0};
    		sum=5*n;
    		scanf("%d",&a[0]);
    		sum+=6*a[0];
    		for(int t=1; t<n; t++) {
    			scanf("%d",&a[t]);
    			if(a[t]-a[t-1]>0) {
    				sum+=(a[t]-a[t-1])*6;
    			} else {
    				sum+=abs(a[t]-a[t-1])*4;
    			}
    		}
    		cout<<sum<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    jquery 只能输入汉字
    实现鼠标移到某个对象,在旁边显示层。
    jquery 清空页面中radio选项
    oracle 删除表中重复的数据
    jQuery 获取屏幕高度、宽度
    jquery清空from表单中的所有数据
    oracle sql语句大全
    mysql sql语句大全
    Java精品书籍推荐
    小萌库
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10782006.html
Copyright © 2020-2023  润新知