• Poj 3253 Fence Repair(哈夫曼树)


    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤ N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to makeN-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    分析:逆向思维,组合各个木板,构造哈夫曼树。在实现哈夫曼树的过程中用优先队列,由于每次往队列里加元素时都要排序,所以实现了Comparator接口,这样就会自动排序了。由于数据较大,输出结果用了大数。
    import java.math.BigInteger;
    import java.util.Comparator;
    import java.util.PriorityQueue;
    import java.util.Scanner;
    
    class Comparators implements Comparator<Integer>{
        @Override
        public int compare(Integer o1, Integer o2) {
            return o1-o2;
        }
    }
    public class Main {
    	
    	
    	public static void main(String[] args) {
    		Scanner sc = new Scanner(System.in);
    		int n=sc.nextInt();
    		Comparators comparator=new Comparators();
    		PriorityQueue<Integer> queue=new PriorityQueue<Integer>(20001,comparator);
    		int a[]=new int[n];
    		for(int i=0;i<n;i++){
    			a[i]=sc.nextInt();
    		}
    		
    		for(int i=0;i<n;i++){
    			queue.add(a[i]);
    		}
    		BigInteger total = BigInteger.ZERO;
    		while(queue.size()!=1){
    			int m=queue.poll();
    			int l=queue.poll();
    			int sum=m+l;
    			queue.add(sum);
    			total=total.add(BigInteger.valueOf(sum));
    		}
    		System.out.println(total);
    	}
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    CF600E Lomsat gelral 题解
    特征工程高级特征开发
    mysql 实现 TOP n
    python调用百度的情感分析API过程
    使用python建立ARIMA模型
    PYTHON 提取HTML文本
    推荐算法架构
    python json 格式化 打印
    教你用PyTorch部署模型的方法
    python 精准 四舍五入方法
  • 原文地址:https://www.cnblogs.com/AndyDai/p/4734094.html
Copyright © 2020-2023  润新知