• 考研编程练习---StringMatching(后缀表达式)


    题目描述:

        Finding all occurrences of a pattern in a text is a problem that arises frequently in text-editing programs.
        Typically,the text is a document being edited,and the pattern searched for is a particular word supplied by the user.  
        We assume that the text is an array T[1..n] of length n and that the pattern is an array P[1..m] of length m<=n.We further assume that the elements of P and  T are all alphabets(∑={a,b...,z}).The character arrays P and T are often called strings of characters.  
        We say that pattern P occurs with shift s in the text T if 0<=s<=n and T[s+1..s+m] = P[1..m](that is if T[s+j]=P[j],for 1<=j<=m).  
        If P occurs with shift s in T,then we call s a valid shift;otherwise,we calls a invalid shift. 
        Your task is to calculate the number of vald shifts for the given text T and p attern P.

    输入:

       For each case, there are two strings T and P on a line,separated by a single space.You may assume both the length of T and P will not exceed 10^6.

    输出:

        You should output a number on a separate line,which indicates the number of valid shifts for the given text T and pattern P.

    样例输入:
    abababab abab
    样例输出:
    3
    经典代码:
    #include <iostream>
    #include <string>
    using namespace std;

    string t,p;
    string s;

    int main(int argc,char* argv[]){
        while(cin>>t>>p){
            int c = 0;
            for(int i=0;i<t.length()-p.length()+1;i++){
                s = t.substr(i,p.length());
                if(p==s){
                    c++;
                }
            }
            cout<<c<<endl;
        }
        return 0;
    }
  • 相关阅读:
    关于2019-nCoV事件中新媒体的作用
    评估移民宇宙计划
    关于2019-nCoV事件,分析自己的焦虑心理
    肺炎阴云仍未散去,今天捡到一个贝壳
    关于新型肺炎,重点是毒性
    提高效率的方法
    《白说》读书笔记
    MIPS下载运行busybox
    camera模组笔记
    求知领域
  • 原文地址:https://www.cnblogs.com/Alex0111/p/4655548.html
Copyright © 2020-2023  润新知