• Train Problem I


    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8757    Accepted Submission(s): 3221


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    
    
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    
    
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    
    
    Sample Input
    3 123 321 3 123 312
     
    
    
    Sample Output
    Yes. in in in out out out FINISH No. FINISH
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     
    
    
    Author
    Ignatius.L
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    int main()
    {
    char stack[10000],in[10000],out[10000];
    int n,top,step,in_out[20000],i,j;
    while(scanf("%d",&n)!=EOF)
    {
    memset(in_out,0,sizeof(in_out));
    scanf("%s %s",in,out);
    step = j = 0;
    top = i = -1;
    stack[++top] = in[++i];
    while(i<n && j<n)
    {
    while(top>=0 && stack[top] == out[j])//无论如何都是要先进站的
    {
    ++j;
    top--;
    in_out[++step] = 1;
    }
    step++;
    stack[++top] = in[++i];
    }
    if(i == n && j==n)//最后如果没有相等,说明栈里面有数字,即不可能
    {
    puts("Yes.");
    for(i = 0;i < step;i++)
    {
    if(!in_out[i])
    puts("in");
    else
    puts("out");
    }

    }
    else
    printf("No.\n");
    puts("FINISH");
    }

    return 0;
    }
  • 相关阅读:
    理解 Go interface 的 5 个关键点
    volcano networkpolicy
    通过 iptables log 日志追踪 Kubernetes 网络
    Network Policy Enforcement
    calico 容器编排之Kubernetes多租户网络隔离
    Kubernetes的原生多租户解决方案
    第四章 计算机基础知识详解
    vue兄弟组件通信
    vue父子组件通信
    Safari浏览器css兼容
  • 原文地址:https://www.cnblogs.com/0803yijia/p/2377748.html
Copyright © 2020-2023  润新知